aboutsummaryrefslogtreecommitdiffstats
path: root/community/kpimtextedit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kpimtextedit/APKBUILD')
-rw-r--r--community/kpimtextedit/APKBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/community/kpimtextedit/APKBUILD b/community/kpimtextedit/APKBUILD
index 6968c8cf8aa..11be35616c4 100644
--- a/community/kpimtextedit/APKBUILD
+++ b/community/kpimtextedit/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kpimtextedit
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="Advanced text editor which provide advanced html feature"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://api.kde.org/kdepim/kpimtextedit/html"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends_dev="
@@ -15,35 +17,36 @@ depends_dev="
kconfig-dev
kconfigwidgets-dev
kcoreaddons-dev
- kemoticons-dev
ki18n-dev
kiconthemes-dev
kio-dev
+ ktextaddons-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
- samurai
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
sonnet-dev
syntax-highlighting-dev
"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev"
+makedepends="$depends_dev
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kpimtextedit.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_DESIGNERPLUGIN=ON
+ -DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
-
# kpimtextedit-plaintext-textgotolinewidgettest,
# kpimtextedit-composerng-richtextcomposertest and
# kpimtextedit-composerng-richtextcomposercontrolertest require OpenGL
@@ -63,12 +66,12 @@ check() {
skipped_tests="$skipped_tests|$test"
done
skipped_tests="$skipped_tests)test"
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "$skipped_tests"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-68a89125dbd4c45b2db825af3cea3c8bf38028f26eca021fc61d8982f25ce33722f0da3cf1d8f0f0f4b9d2e8e5613f0af6010756f064e89fabd305a905521443 kpimtextedit-22.04.2.tar.xz
+c48e3ca5fc2b53f8b04cdbd42db32045131fbf4e63b49e005c265ee3deef58d37c34e434842a1de6ce72a59e46deb4863689320b85961c7a3ea8c6dc50bc0db6 kpimtextedit-24.02.2.tar.xz
"