aboutsummaryrefslogtreecommitdiffstats
path: root/community/kplotting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kplotting/APKBUILD')
-rw-r--r--community/kplotting/APKBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/community/kplotting/APKBUILD b/community/kplotting/APKBUILD
index 48bb01c4cbd..869fe7c7b71 100644
--- a/community/kplotting/APKBUILD
+++ b/community/kplotting/APKBUILD
@@ -1,21 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kplotting
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Lightweight plotting framework"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+depends_dev="qt6-qtbase-dev"
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kplotting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -23,14 +32,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-04a3161ed32d4d334eff121c7cdc8840f852b8c5b60f880f4b98a5710e2861fe93ceca836efd5c74067ef3785d083b2a610526df17a358d8327942b9648767b4 kplotting-5.90.0.tar.xz
+10af7aa2397185fcdc7a4f7c6eb2c2a8925f3da15fa6878501d1f3100c3e30849fd227e6412eb419f7382add97dad59115ca72e00f69d8cdc2fc00d76bece00d kplotting-6.1.0.tar.xz
"