aboutsummaryrefslogtreecommitdiffstats
path: root/community/kplotting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kplotting/APKBUILD')
-rw-r--r--community/kplotting/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/kplotting/APKBUILD b/community/kplotting/APKBUILD
index e1ff369905e..869fe7c7b71 100644
--- a/community/kplotting/APKBUILD
+++ b/community/kplotting/APKBUILD
@@ -1,17 +1,26 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kplotting
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Lightweight plotting framework"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev samurai"
+depends_dev="qt6-qtbase-dev"
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kplotting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -23,14 +32,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-612feaf9860a8a1a73897a5d4dd4468c72b9b347b0aea6acf48041ec067d79f8d504d9d8ca5207984c8c18a4989c8af776b91fb28cddf7a5618b06b54ad206f3 kplotting-5.95.0.tar.xz
+10af7aa2397185fcdc7a4f7c6eb2c2a8925f3da15fa6878501d1f3100c3e30849fd227e6412eb419f7382add97dad59115ca72e00f69d8cdc2fc00d76bece00d kplotting-6.1.0.tar.xz
"