aboutsummaryrefslogtreecommitdiffstats
path: root/community/kpmcore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kpmcore/APKBUILD')
-rw-r--r--community/kpmcore/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/kpmcore/APKBUILD b/community/kpmcore/APKBUILD
index 9d8135cccb5..6d4a65c34cf 100644
--- a/community/kpmcore/APKBUILD
+++ b/community/kpmcore/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kpmcore
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kauth
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/org.kde.partitionmanager"
pkgdesc="Library for managing partitions"
license="GPL-3.0-or-later"
@@ -20,28 +22,29 @@ makedepends="
kcoreaddons-dev
ki18n-dev
kwidgetsaddons-dev
- qca-dev
- qt5-qtbase-dev
+ qca-qt6-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kpmcore-$pkgver.tar.xz"
+checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # Requires running dbus server
+_repo_url="https://invent.kde.org/system/kpmcore.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kpmcore-$pkgver.tar.xz"
# secfixes:
# 4.2.0-r0:
# - CVE-2020-27187
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
package() {
@@ -49,5 +52,5 @@ package() {
}
sha512sums="
-44614e3a0db646b81e56b87daa841b7b7e03ff97699ea393d83b6cc61e6c12efa36ac6b8aba87da612f2973a1d108bdad21ef0d73fc2db98595e5b711e5a0fcf kpmcore-21.04.3.tar.xz
+24664d79e4fbc630ecdbc08006de2bc6a1d42abd1eeeb842b00c45a17742ae651c0c5a490310d99803b6dfe757f4fcc0a66c211dd2afbbafd4cd8cfb30050bd0 kpmcore-24.02.2.tar.xz
"