aboutsummaryrefslogtreecommitdiffstats
path: root/community/kpty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kpty/APKBUILD')
-rw-r--r--community/kpty/APKBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/community/kpty/APKBUILD b/community/kpty/APKBUILD
index 885fce56787..614e5a68e14 100644
--- a/community/kpty/APKBUILD
+++ b/community/kpty/APKBUILD
@@ -1,21 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kpty
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Pty abstraction"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev kcoreaddons-dev ki18n-dev libutempter-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kpty-$pkgver.tar.xz"
+depends_dev="
+ kcoreaddons-dev
+ ki18n-dev
+ libutempter-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # The one test it has fails: "Can't open a pseudo teletype"
+_repo_url="https://invent.kde.org/frameworks/kpty.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kpty-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -23,13 +36,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "kptyprocesstest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-656a066996ee781fc4ccf94ea330d7c4e08c6a5520a93e961da1649ebbc464222dd48e988265f7280085a67efb20d3f433c9c78f9ac3266ad454e3c10b114cda kpty-5.90.0.tar.xz
+bf369464be4d7d4391a48d5880752a36bf74f885678557d435f29749a7135c1bf47a5e97390436da4d44d78a65632be6cd34f50ce0c8c6c6a9cc68c8be02f958 kpty-6.1.0.tar.xz
"