aboutsummaryrefslogtreecommitdiffstats
path: root/community/kquickcharts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kquickcharts/APKBUILD')
-rw-r--r--community/kquickcharts/APKBUILD39
1 files changed, 26 insertions, 13 deletions
diff --git a/community/kquickcharts/APKBUILD b/community/kquickcharts/APKBUILD
index b924cf88361..b23a7f545c0 100644
--- a/community/kquickcharts/APKBUILD
+++ b/community/kquickcharts/APKBUILD
@@ -1,33 +1,46 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kquickcharts
-pkgver=5.70.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="A QtQuick plugin providing high-performance charts"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev"
-makedepends="$depends_dev extra-cmake-modules"
+depends_dev="$pkgname=$pkgver-r$pkgrel
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kquickcharts-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/kquickcharts.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kquickcharts-$pkgver.tar.xz"
+# Requires working OpenGL
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
-
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="0579b7516eacfd138216a854ef5bc9ad4b7b84a5a8255498c2454b931f13f0097905689a5b602e88b24dbd9d2782828cee861974b856a57e0d4ce51ced7117ef kquickcharts-5.70.0.tar.xz"
+
+sha512sums="
+a3f25ff4ad0324b04d5bd2496e3bb3dc6cfcebdab52ccb1dcf52d0e36ae2d699c6c19651d2f399bac54236cceb696c0b64cca4f697582a75e7cc3b572c02df48 kquickcharts-6.1.0.tar.xz
+"