aboutsummaryrefslogtreecommitdiffstats
path: root/community/kquickimageeditor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kquickimageeditor/APKBUILD')
-rw-r--r--community/kquickimageeditor/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/kquickimageeditor/APKBUILD b/community/kquickimageeditor/APKBUILD
index 394322fe8ff..855574f732a 100644
--- a/community/kquickimageeditor/APKBUILD
+++ b/community/kquickimageeditor/APKBUILD
@@ -1,27 +1,29 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kquickimageeditor
-pkgver=0.2.0
-pkgrel=0
+pkgver=0.3.0
+pkgrel=2
pkgdesc="Simple image editor for QtQuick applications"
url="https://invent.kde.org/libraries/kquickimageeditor"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
license="BSD-2-Clause AND LGPL-2.1-or-later"
depends_dev="
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/kquickimageeditor/kquickimageeditor-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+source="https://download.kde.org/stable/kquickimageeditor/kquickimageeditor-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -32,5 +34,5 @@ package() {
}
sha512sums="
-86a2abb6d07737bbfff1e6395d6610bd24384c9e376fac74092d6d7fa888beb03c378e3e8cfeaca1a38a54c54ef8721098efb832154c9fcd22d27355f186ad65 kquickimageeditor-0.2.0.tar.xz
+51f25c5f2089c2bc9ef4715a4535b72cbf50664d17fe23dc80b266831d65a525027fa16d111400d4cf2c6b8210cbd572a3b3a0e4e921d42d331905718364ad7f kquickimageeditor-0.3.0.tar.xz
"