aboutsummaryrefslogtreecommitdiffstats
path: root/community/ksmtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ksmtp/APKBUILD')
-rw-r--r--community/ksmtp/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/ksmtp/APKBUILD b/community/ksmtp/APKBUILD
index d950935f113..5a2e2213355 100644
--- a/community/ksmtp/APKBUILD
+++ b/community/ksmtp/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ksmtp
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="Job-based library to send email through an SMTP server"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kontact.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
@@ -14,31 +16,37 @@ depends_dev="
kcoreaddons-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/ksmtp.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ksmtp-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # Broken
+# The single test is broken
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-e313e1056b7d4cfa6c425c2987658f2d989658cfecfe84278e3c755a090f980a1bd151bfdcf5cc49f713f504b7dda69c1224d05aa25b87783f0a76e87db59f95 ksmtp-21.12.1.tar.xz
+6d81edae32ed912badb6886da44013437f8d307898e6ab9feaa2c0426ce1e3bc69c089f30bc341cac231f191bf484ab1184511fb0c95c79b706af0800b0b5258 ksmtp-24.02.2.tar.xz
"