aboutsummaryrefslogtreecommitdiffstats
path: root/community/ksmtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ksmtp/APKBUILD')
-rw-r--r--community/ksmtp/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/ksmtp/APKBUILD b/community/ksmtp/APKBUILD
index 018fbf2d547..31395638da8 100644
--- a/community/ksmtp/APKBUILD
+++ b/community/ksmtp/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ksmtp
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
pkgdesc="Job-based library to send email through an SMTP server"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kontact.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
@@ -14,27 +16,31 @@ depends_dev="
kcoreaddons-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/ksmtp.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ksmtp-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # Broken
+# The single test is broken
+options="!check"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +48,5 @@ package() {
}
sha512sums="
-a7a02c146733bb6755e1c7c342b04b8a4959ebca3ef8ea948e377a3cd206f215dab867654e885bbb02fa8b0746636f38352883da51e68acfffb6252468d8d988 ksmtp-22.04.2.tar.xz
+fece1f6d6fd08ca11580abd3ba1fdfa56d72b5cbf601e3232793b713082e11f27f09f63e881ac138f3daa07675a9d04abebda7204af309424da47c04b06d3018 ksmtp-24.02.1.tar.xz
"