aboutsummaryrefslogtreecommitdiffstats
path: root/community/kteatime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kteatime/APKBUILD')
-rw-r--r--community/kteatime/APKBUILD36
1 files changed, 27 insertions, 9 deletions
diff --git a/community/kteatime/APKBUILD b/community/kteatime/APKBUILD
index 5f42fd58a09..04067a91d4c 100644
--- a/community/kteatime/APKBUILD
+++ b/community/kteatime/APKBUILD
@@ -1,17 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kteatime
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kteatime"
pkgdesc="A handy timer for steeping tea"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev kcrash-dev kdoctools-dev ki18n-dev kiconthemes-dev knotifyconfig-dev knotifications-dev ktextwidgets-dev kxmlgui-dev kconfig-dev samurai"
+makedepends="
+ extra-cmake-modules
+ kconfig-dev
+ kconfig-dev
+ kcrash-dev
+ kdoctools-dev
+ ki18n-dev
+ kiconthemes-dev
+ knotifications-dev
+ knotifyconfig-dev
+ ktextwidgets-dev
+ kxmlgui-dev
+ qt6-qtbase-dev
+ samurai
+ "
+subpackages=" $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kteatime.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kteatime-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+# No tests
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -22,9 +40,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-3310292f793dd53babc1f6e1c35bf0c7b75a9bb3e347980d18bd42328af2485e61c4fd7b9a0cc38677cb293ef292e3c1644f724e54e8ee11bcefae055b849f32 kteatime-22.04.3.tar.xz
+35b47e2c0081c093c0c15bef2a1d3b591d110e452a961776b76cff10fa53ec3a8b0826a5c6d168e5869e9e867864c3a50884031e90e586ff04a9e7731e4d0b2b kteatime-24.02.2.tar.xz
"