aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktexteditor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktexteditor/APKBUILD')
-rw-r--r--community/ktexteditor/APKBUILD72
1 files changed, 59 insertions, 13 deletions
diff --git a/community/ktexteditor/APKBUILD b/community/ktexteditor/APKBUILD
index 2925890637a..341d431b19b 100644
--- a/community/ktexteditor/APKBUILD
+++ b/community/ktexteditor/APKBUILD
@@ -1,22 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=ktexteditor
-pkgver=5.82.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Advanced embeddable text editor"
-arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.0-only OR LGPL-3.0-only)"
-depends_dev="karchive-dev kconfig-dev kguiaddons-dev ki18n-dev kio-dev kparts-dev sonnet-dev kiconthemes-dev syntax-highlighting-dev kauth-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+depends_dev="
+ karchive-dev
+ kauth-dev
+ kconfig-dev
+ kguiaddons-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ kparts-dev
+ sonnet-dev
+ syntax-highlighting-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-options="!check" # fail on builders
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ktexteditor-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/ktexteditor.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ktexteditor-$pkgver.tar.xz"
+
+replaces="ktexteditor5"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -24,13 +46,37 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ local skipped_tests="("
+ local tests="
+ encoding_utf8.txt_diff
+ encoding_latin15.txt_diff
+ encoding_utf32.txt_diff
+ encoding_utf16.txt_diff
+ encoding_utf32be.txt_diff
+ encoding_utf16be.txt_diff
+ encoding_cyrillic_utf8.txt_diff
+ encoding_cp1251.txt_diff
+ encoding_koi8-r.txt_diff
+ encoding_one-char-latin-15.txt_diff
+ encoding_latin15-with-utf8-bom.txt_diff
+ "
+ case "$CARCH" in
+ s390x) tests="$tests
+ encodingtest
+ messagetest
+ " ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-1459ba61ed4a4b603cd984449a217230914818e32c318a92232957cc83d5e70f2a55bf150ca946252c696e019c24dee5b852ca5046c9914f3fff1c6906487bdf ktexteditor-5.82.0.tar.xz
+c178822fdbce8738c41853b3ee2b5ee961c29efbc486ee4f3f9f073110c1c77abf9fd0310c4d68461f09e9b3d0ca47662b4e950be8d358e0be7d2141836fafd2 ktexteditor-6.1.0.tar.xz
"