aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktimer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktimer/APKBUILD')
-rw-r--r--community/ktimer/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/ktimer/APKBUILD b/community/ktimer/APKBUILD
index 3bd862c8beb..706f299ec55 100644
--- a/community/ktimer/APKBUILD
+++ b/community/ktimer/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktimer
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
pkgdesc="A little tool to execute programs after some time"
# armhf blocked by extra-cmake-modules
@@ -16,13 +19,14 @@ makedepends="
ki18n-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/ktimer.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -34,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +46,5 @@ package() {
}
sha512sums="
-dd7c1013a8aaa585a85721ab557d890a8476fa282338e9bc12397cde0b0475582db7bbbbdcae79c68e59f74716bc92742db9b1480b6a91ca3fad3b02e413c062 ktimer-22.08.0.tar.xz
+0f68b6b12f3db428f1349f7d9ede8d1f77d5b1ff8fe3a575c211b235a05d33c5ddde2f4e9e520b13eac5778a8125e65b32d2188dfcb600f5f0341b67d669fc35 ktimer-24.02.2.tar.xz
"