aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktimer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktimer/APKBUILD')
-rw-r--r--community/ktimer/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/ktimer/APKBUILD b/community/ktimer/APKBUILD
index fe60fa2bdc4..706f299ec55 100644
--- a/community/ktimer/APKBUILD
+++ b/community/ktimer/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktimer
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="A little tool to execute programs after some time"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.ktimer"
license="GPL-2.0-or-later"
makedepends="
@@ -17,24 +19,26 @@ makedepends="
ki18n-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/ktimer.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKF_IGNORE_PLATFORM_CHECK=ON # does not have metainfo.yaml
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-3cf8a0387174202ffaab9e901cc4e6bf851403b21d8b34df6b437f13d310a7bd657438fb1c10eb0b238d3d6407334987db4b94433d27187d1cfaacf23c09bc2d ktimer-21.04.3.tar.xz
+0f68b6b12f3db428f1349f7d9ede8d1f77d5b1ff8fe3a575c211b235a05d33c5ddde2f4e9e520b13eac5778a8125e65b32d2188dfcb600f5f0341b67d669fc35 ktimer-24.02.2.tar.xz
"