aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktimer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktimer/APKBUILD')
-rw-r--r--community/ktimer/APKBUILD44
1 files changed, 31 insertions, 13 deletions
diff --git a/community/ktimer/APKBUILD b/community/ktimer/APKBUILD
index 008e32944a4..706f299ec55 100644
--- a/community/ktimer/APKBUILD
+++ b/community/ktimer/APKBUILD
@@ -1,32 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktimer
-pkgver=20.04.1
+pkgver=24.02.2
pkgrel=0
+pkgdesc="A little tool to execute programs after some time"
+# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.ktimer"
-pkgdesc="A little tool to execute programs after some time"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev ki18n-dev kwidgetsaddons-dev kio-dev kdbusaddons-dev knotifications-dev kconfig-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ kconfig-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ knotifications-dev
+ kstatusnotifieritem-dev
+ kwidgetsaddons-dev
+ qt6-qtbase-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/ktimer.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKF_IGNORE_PLATFORM_CHECK=ON # does not have metainfo.yaml
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="f1b0f4520578302e669f58641dd45a0bea203da8e4779e151edec584f45ea445e60a6047cc32513b2d7a9f5a1293f378087413008c930217a2fb2fd7eb62b984 ktimer-20.04.1.tar.xz"
+sha512sums="
+0f68b6b12f3db428f1349f7d9ede8d1f77d5b1ff8fe3a575c211b235a05d33c5ddde2f4e9e520b13eac5778a8125e65b32d2188dfcb600f5f0341b67d669fc35 ktimer-24.02.2.tar.xz
+"