aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktorrent/APKBUILD')
-rw-r--r--community/ktorrent/APKBUILD60
1 files changed, 32 insertions, 28 deletions
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index 8bb873eee6c..65f721584f2 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktorrent
-pkgver=22.08.0
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
@@ -12,42 +15,43 @@ license="GPL-2.0-or-later"
makedepends="
boost-dev
extra-cmake-modules
- karchive-dev
- kcmutils-dev
- kcompletion-dev
- kconfig-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdnssd-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kio-dev
- kitemviews-dev
- knotifications-dev
- knotifyconfig-dev
- kparts-dev
- kplotting-dev
+ karchive5-dev
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdnssd5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ kitemviews5-dev
+ knotifications5-dev
+ knotifyconfig5-dev
+ kparts5-dev
+ kplotting5-dev
kross-dev
- ktextwidgets-dev
- kwidgetsaddons-dev
- kwindowsystem-dev
- kxmlgui-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
libktorrent-dev
phonon-dev
plasma-workspace-dev
qt5-qtbase-dev
qt5-qtwebengine-dev
samurai
- solid-dev
- syndication-dev
+ solid5-dev
+ syndication5-dev
taglib-dev
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/network/ktorrent.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ktorrent-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-lang"
build() {
# The infowidget plugin is disabled due to an incompatibility with musl
@@ -71,5 +75,5 @@ package() {
}
sha512sums="
-3d9c7c90358d6903b96c6fc94815d8db0929e8109cd960382d42eecf91f408b2302caa75c2275ccdc57756b0ae107c653322867cc52be6656be4e50a58980d6a ktorrent-22.08.0.tar.xz
+c5347c0c9208c6a8be7ea819ba34a0fb657e12aec7d55ad280f70f2f5ad63654a99d323f3a0b0f7d15221317bc53a5f2e9af018bf4e18dd69a326213b783ad3d ktorrent-24.02.1.tar.xz
"