aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktorrent/APKBUILD')
-rw-r--r--community/ktorrent/APKBUILD64
1 files changed, 34 insertions, 30 deletions
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index b80e3c0f07c..599d83ea402 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -1,10 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktorrent
-pkgver=22.04.2
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by polkit -> plasma-workspace
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
@@ -12,42 +15,43 @@ license="GPL-2.0-or-later"
makedepends="
boost-dev
extra-cmake-modules
- karchive-dev
- kcmutils-dev
- kcompletion-dev
- kconfig-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdnssd-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kio-dev
- kitemviews-dev
- knotifications-dev
- knotifyconfig-dev
- kparts-dev
- kplotting-dev
+ karchive5-dev
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdnssd5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ kitemviews5-dev
+ knotifications5-dev
+ knotifyconfig5-dev
+ kparts5-dev
+ kplotting5-dev
kross-dev
- ktextwidgets-dev
- kwidgetsaddons-dev
- kwindowsystem-dev
- kxmlgui-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
libktorrent-dev
phonon-dev
plasma-workspace-dev
qt5-qtbase-dev
qt5-qtwebengine-dev
samurai
- solid-dev
- syndication-dev
+ solid5-dev
+ syndication5-dev
taglib-dev
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/network/ktorrent.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ktorrent-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-lang"
build() {
# The infowidget plugin is disabled due to an incompatibility with musl
@@ -71,5 +75,5 @@ package() {
}
sha512sums="
-8953e7bed3b24031941b1eb8bd09f0b62f6efd6b9bca228ba773f260c76f716f7535947f0fc01e285e257ed71e82a740cd976c41b4e9de76e54e75d7f7ffe076 ktorrent-22.04.2.tar.xz
+d623cad02bf524795c514a859360e29a6608299a7327d43ba2e07f0520bd487c24c94f1aa17d5193454fb8b18059b79c27fa88e867f249e204b83f2c08f6e9a0 ktorrent-24.02.2.tar.xz
"