aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktorrent/APKBUILD')
-rw-r--r--community/ktorrent/APKBUILD70
1 files changed, 37 insertions, 33 deletions
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index 63e18768095..65f721584f2 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -1,58 +1,62 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktorrent
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by polkit -> plasma-workspace
-# mips64 blocked by libktorrent
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
makedepends="
boost-dev
extra-cmake-modules
- karchive-dev
- kcmutils-dev
- kcompletion-dev
- kconfig-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdnssd-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kio-dev
- kitemviews-dev
- knotifications-dev
- knotifyconfig-dev
- kparts-dev
- kplotting-dev
+ karchive5-dev
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdnssd5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ kitemviews5-dev
+ knotifications5-dev
+ knotifyconfig5-dev
+ kparts5-dev
+ kplotting5-dev
kross-dev
- ktextwidgets-dev
- kwidgetsaddons-dev
- kwindowsystem-dev
- kxmlgui-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
libktorrent-dev
phonon-dev
plasma-workspace-dev
qt5-qtbase-dev
qt5-qtwebengine-dev
- solid-dev
- syndication-dev
+ samurai
+ solid5-dev
+ syndication5-dev
taglib-dev
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/network/ktorrent.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ktorrent-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-lang"
build() {
# The infowidget plugin is disabled due to an incompatibility with musl
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_INFOWIDGET_PLUGIN=FALSE
@@ -71,5 +75,5 @@ package() {
}
sha512sums="
-dab7e6d1bae0af1d0cd2dcea2083c4b99bb0e23da5bd3a41a2b7249c04f5b3f75dec892f1d8309e635afd1f5b36b9f51b6bc752e2c6890b5b16290226872b59d ktorrent-21.12.1.tar.xz
+c5347c0c9208c6a8be7ea819ba34a0fb657e12aec7d55ad280f70f2f5ad63654a99d323f3a0b0f7d15221317bc53a5f2e9af018bf4e18dd69a326213b783ad3d ktorrent-24.02.1.tar.xz
"