aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktorrent/APKBUILD')
-rw-r--r--community/ktorrent/APKBUILD72
1 files changed, 38 insertions, 34 deletions
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index f80002a5b69..599d83ea402 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -1,58 +1,62 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktorrent
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by polkit -> plasma-workspace
-# mips64 blocked by libktorrent
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
makedepends="
boost-dev
extra-cmake-modules
- karchive-dev
- kcmutils-dev
- kcompletion-dev
- kconfig-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdewebkit-dev
- kdnssd-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kio-dev
- kitemviews-dev
- knotifications-dev
- knotifyconfig-dev
- kparts-dev
- kplotting-dev
+ karchive5-dev
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdnssd5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kio5-dev
+ kitemviews5-dev
+ knotifications5-dev
+ knotifyconfig5-dev
+ kparts5-dev
+ kplotting5-dev
kross-dev
- ktextwidgets-dev
- kwidgetsaddons-dev
- kwindowsystem-dev
- kxmlgui-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
libktorrent-dev
phonon-dev
plasma-workspace-dev
qt5-qtbase-dev
- solid-dev
- syndication-dev
+ qt5-qtwebengine-dev
+ samurai
+ solid5-dev
+ syndication5-dev
taglib-dev
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/network/ktorrent.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/ktorrent-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-lang"
build() {
# The infowidget plugin is disabled due to an incompatibility with musl
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_INFOWIDGET_PLUGIN=FALSE
@@ -71,5 +75,5 @@ package() {
}
sha512sums="
-70e8baf2d04fe86be09fd4583ba20375ccbec67e5e8b7a8aac252bbe04469ccfb36c55fc5088497f8575f3bef59cff40f48f648d73071e06f676b45504aa935e ktorrent-21.04.3.tar.xz
+d623cad02bf524795c514a859360e29a6608299a7327d43ba2e07f0520bd487c24c94f1aa17d5193454fb8b18059b79c27fa88e867f249e204b83f2c08f6e9a0 ktorrent-24.02.2.tar.xz
"