aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktouch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktouch/APKBUILD')
-rw-r--r--community/ktouch/APKBUILD53
1 files changed, 41 insertions, 12 deletions
diff --git a/community/ktouch/APKBUILD b/community/ktouch/APKBUILD
index 8ffb390dfed..1cd75109ff4 100644
--- a/community/ktouch/APKBUILD
+++ b/community/ktouch/APKBUILD
@@ -1,32 +1,61 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktouch
-pkgver=21.04.0
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf !mips !mips64 !s390x" # armhf blocked by qt5-qtdeclarative, everything else by rust
+# armhf blocked by qt5-qtdeclarative
+arch="all !armhf"
url="https://edu.kde.org/ktouch/"
pkgdesc="Touch Typing Tutor"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev qt5-qtxmlpatterns-dev qt5-qtx11extras-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev ki18n-dev kitemviews-dev kcmutils-dev ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kiconthemes-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ktouch-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kdeclarative5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kitemviews5-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
+ libx11-dev
+ libxcb-dev
+ libxkbfile-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ qt5-qtx11extras-dev
+ qt5-qtxmlpatterns-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/ktouch.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktouch-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="efb2364f9f0c55f670d3b99976c5c9f4dfc8a646c88481d475816f54c88ecc6dbdc49b028d2ff36e7848baf62553bfbe3ec5938a5f16cf9c84265e23f5eb8a9f ktouch-21.04.0.tar.xz"
+sha512sums="
+3adedfde86dabfc6cd9acaeeb3bd4255f8ab0ec5d32d02f6175ff475ef79d2bed65783b795466f097550a66b3de7361aaab3f3ea3ac2a4be8e317de542b0ba76 ktouch-24.02.2.tar.xz
+"