aboutsummaryrefslogtreecommitdiffstats
path: root/community/ktouch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ktouch/APKBUILD')
-rw-r--r--community/ktouch/APKBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/community/ktouch/APKBUILD b/community/ktouch/APKBUILD
index 93b1d129af7..1cd75109ff4 100644
--- a/community/ktouch/APKBUILD
+++ b/community/ktouch/APKBUILD
@@ -1,43 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ktouch
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
-# riscv64 and s390x blocked by rust
# armhf blocked by qt5-qtdeclarative
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/ktouch/"
pkgdesc="Touch Typing Tutor"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- kcmutils-dev
- kcompletion-dev
- kconfig-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kdeclarative-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kitemviews-dev
- ktextwidgets-dev
- kwidgetsaddons-dev
- kwindowsystem-dev
- kxmlgui-dev
+ kcmutils5-dev
+ kcompletion5-dev
+ kconfig5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kdeclarative5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kitemviews5-dev
+ ktextwidgets5-dev
+ kwidgetsaddons5-dev
+ kwindowsystem5-dev
+ kxmlgui5-dev
libx11-dev
libxcb-dev
libxkbfile-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
- qt5-qtquickcontrols2-dev
qt5-qtx11extras-dev
qt5-qtxmlpatterns-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ktouch-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/ktouch.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktouch-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -48,8 +49,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -57,5 +57,5 @@ package() {
}
sha512sums="
-af76a027e73c19e793da18f48a9160f7daa5f4153e7c5471cc544482cd18638251dec1daf911de2f5cf89f0ad5975189c583f4aac9b886f0c98ffd785ff0b646 ktouch-22.04.2.tar.xz
+3adedfde86dabfc6cd9acaeeb3bd4255f8ab0ec5d32d02f6175ff475ef79d2bed65783b795466f097550a66b3de7361aaab3f3ea3ac2a4be8e317de542b0ba76 ktouch-24.02.2.tar.xz
"