aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwallet-pam/APKBUILD')
-rw-r--r--community/kwallet-pam/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 576d84b2e61..384288f28b5 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwallet-pam
-pkgver=5.24.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="KWallet PAM integration"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kwallet
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
depends="socat"
@@ -16,21 +18,23 @@ makedepends="
libgcrypt-dev
linux-pam-dev
samurai
- socat
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/kwallet-pam.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DCMAKE_INSTALL_LIBEXECDIR=usr/libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib # for the pam module to be in /lib/security
cmake --build build
}
@@ -38,9 +42,9 @@ package() {
DESTDIR="$pkgdir" cmake --install build
# We don't ship systemd
- rm -r "$pkgdir"/usr/lib/systemd
+ rm -r "$pkgdir"/lib/systemd
}
sha512sums="
-9ce9862b5cc6525b183911cd9d96edeae585cd0d54055fc38a7f2f41febfeb388d31b4aa18f1c36a7068898457af53f560e22a2f5a8a4a015910d56fa70aa740 kwallet-pam-5.24.5.tar.xz
+af186165fe2e2ada5e1dd8359b41980af36e18b5266048fd3dbeeb4e2815ec158a1d1079d0c25ea427dc4c43414bf985c8eea828eafe54d9c58bc4b3c59255c6 kwallet-pam-6.0.4.tar.xz
"