aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwallet-pam/APKBUILD')
-rw-r--r--community/kwallet-pam/APKBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 657ab61e9fd..5a3e0a2949e 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,41 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwallet-pam
-pkgver=5.23.1
+pkgver=6.0.3
pkgrel=0
pkgdesc="KWallet PAM integration"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kwallet
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
+depends="socat"
makedepends="
extra-cmake-modules
kwallet-dev
libgcrypt-dev
linux-pam-dev
- socat
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/kwallet-pam.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DCMAKE_INSTALL_LIBEXECDIR=usr/libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib # for the pam module to be in /lib/security
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/lib/systemd
}
sha512sums="
-0e8369a25fdd1cd8de43f8a13ba0a62dcd03a9f20997cf803957716e5ec14173cb16eac350c14b30e25cfb9f547ece97dbc9deb67ff9a1184626881dde433010 kwallet-pam-5.23.1.tar.xz
+bdef907847de6a9aeef46e3e00488643f9f965b91cec547e6d14e948558aded1738fcf3f84da6de137375945fb67fb5913da5fbaebe0a08e2e313bbabb8e93ed kwallet-pam-6.0.3.tar.xz
"