aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwallet-pam/APKBUILD')
-rw-r--r--community/kwallet-pam/APKBUILD56
1 files changed, 36 insertions, 20 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 7c6b57781db..384288f28b5 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,34 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwallet-pam
-pkgver=5.17.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="KWallet PAM integration"
-arch="all"
-url="https://www.kde.org/workspaces/plasmadesktop/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
-makedepends="extra-cmake-modules linux-pam-dev libgcrypt-dev socat kwallet-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
-options="!check" # No tests available
-
-prepare() {
- default_prepare
+depends="socat"
+makedepends="
+ extra-cmake-modules
+ kwallet-dev
+ libgcrypt-dev
+ linux-pam-dev
+ samurai
+ "
- mkdir "$builddir"/build
-}
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+_repo_url="https://invent.kde.org/plasma/kwallet-pam.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- make
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DCMAKE_INSTALL_LIBEXECDIR=usr/libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib # for the pam module to be in /lib/security
+ cmake --build build
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/lib/systemd
}
-sha512sums="5f3d8408488f6ae1e9b8f1a2e1975ccad3b8ca6bd9ff9a721f7ff83f50259d7a459a66bd48963702669c3751abe467917e0a7ebed5a05ed789a504c5ced29ffc kwallet-pam-5.17.2.tar.xz"
+sha512sums="
+af186165fe2e2ada5e1dd8359b41980af36e18b5266048fd3dbeeb4e2815ec158a1d1079d0c25ea427dc4c43414bf985c8eea828eafe54d9c58bc4b3c59255c6 kwallet-pam-6.0.4.tar.xz
+"