aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwallet-pam/APKBUILD')
-rw-r--r--community/kwallet-pam/APKBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 2470d9f8f2f..384288f28b5 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,41 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwallet-pam
-pkgver=5.22.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="KWallet PAM integration"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kwallet
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
+depends="socat"
makedepends="
extra-cmake-modules
kwallet-dev
libgcrypt-dev
linux-pam-dev
- socat
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/kwallet-pam.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DCMAKE_INSTALL_LIBEXECDIR=usr/libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib # for the pam module to be in /lib/security
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/lib/systemd
}
sha512sums="
-230135ee7aadbbc9f08695afa87fd7d8f0e3dca5da40f94bea92ad83a8a2ccc86efb7d593730079a0affc91f28383d089a08fd2b4db57961ba7c5b3a009a6038 kwallet-pam-5.22.5.tar.xz
+af186165fe2e2ada5e1dd8359b41980af36e18b5266048fd3dbeeb4e2815ec158a1d1079d0c25ea427dc4c43414bf985c8eea828eafe54d9c58bc4b3c59255c6 kwallet-pam-6.0.4.tar.xz
"