aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwallet/APKBUILD')
-rw-r--r--community/kwallet/APKBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/community/kwallet/APKBUILD b/community/kwallet/APKBUILD
index d5061f9b811..c9b307861d7 100644
--- a/community/kwallet/APKBUILD
+++ b/community/kwallet/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kwallet
-pkgver=5.88.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Secure and unified container for user passwords"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
@@ -21,27 +23,27 @@ depends_dev="
kservice-dev
kwindowsystem-dev
libgcrypt-dev
+ qca-qt6-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
kdoctools-dev
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-bin"
+_repo_url="https://invent.kde.org/frameworks/kwallet.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwallet-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
provides="dbus:org.freedesktop.Secrets"
# 2nd highst priority after gnome-keyring, mainly for KDE
provider_priority=10
-case "$CARCH" in
- mips*) options="!check";;
-esac
-
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -49,18 +51,29 @@ build() {
}
check() {
- cd build
-
local excluded_checks=
case "$CARCH" in
s390x) excluded_checks="(blowfishtest)";;
esac
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "$excluded_checks"
+ ctest --test-dir build --output-on-failure -E "$excluded_checks"
}
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ rm "$pkgdir"/usr/share/dbus-1/services/org.kde.kwalletd5.service
}
+
+doc() {
+ replaces="kwallet5-doc"
+
+ default_doc
+}
+
+bin() {
+ amove usr/bin/kwallet-query
+}
+
sha512sums="
-ad12f9d9162181962006b6f51fde52344de15e384bb69e9c48fc376625175a3a3aafd9093f3cdaa5d99735c9fc88954c16353b14c0d4499e488008307918b847 kwallet-5.88.0.tar.xz
+fb0428a76788d556ffc6c18a649f5e4de96b57234931e2e878ea660c612384c9778367db26089d73f0499b0d5d5cffcc9b193ca97a03aa3504180b483170c88b kwallet-6.1.0.tar.xz
"