aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland-integration/APKBUILD')
-rw-r--r--community/kwayland-integration/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 801fb187f4f..ab4ec165113 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,20 +1,24 @@
# Contributor: Bhushan Shah <bshah@kde.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland-integration
-pkgver=5.23.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="KWayland integration"
url="https://kde.org/plasma-desktop/"
arch="all !armhf" # armhf blocked by extra-cmake-modules
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends="kglobalaccel"
+depends="kglobalaccel5"
makedepends="
extra-cmake-modules
- kguiaddons-dev
- kidletime-dev
- kwayland-dev
- kwindowsystem-dev
+ kguiaddons5-dev
+ kidletime5-dev
+ kwayland5-dev
+ kwindowsystem5-dev
qt5-qtbase-dev
+ samurai
wayland-protocols
"
@@ -22,12 +26,13 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
+_repo_url="https://invent.kde.org/plasma/kwayland-integration.git"
source="https://download.kde.org/$_rel/plasma/$pkgver/kwayland-integration-$pkgver.tar.xz"
options="!check" # Broken
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -38,5 +43,5 @@ package() {
}
sha512sums="
-105ee9df541cd6c167fd3434ac846a065c20b82b85c57a2d465c17256567fc7ee717f2fbae4f6acad61c4a6111f6262a2dc7e3fe23cab0bbb3ae2e478ef4ec19 kwayland-integration-5.23.5.tar.xz
+0caf516444afb9fa5b148461f1301fb865c691ad39f120c3919194be643492721210a2c1a584f8bcacef9ad2fd2f04a563eb18e3b388bb4322574fd0f2d590af kwayland-integration-6.0.3.tar.xz
"