aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland-integration/APKBUILD')
-rw-r--r--community/kwayland-integration/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 1255813c21e..ab4ec165113 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,32 +1,38 @@
# Contributor: Bhushan Shah <bshah@kde.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland-integration
-pkgver=5.22.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="KWayland integration"
url="https://kde.org/plasma-desktop/"
arch="all !armhf" # armhf blocked by extra-cmake-modules
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends="kglobalaccel"
+depends="kglobalaccel5"
makedepends="
extra-cmake-modules
- kguiaddons-dev
- kidletime-dev
- kwayland-dev
- kwindowsystem-dev
+ kguiaddons5-dev
+ kidletime5-dev
+ kwayland5-dev
+ kwindowsystem5-dev
qt5-qtbase-dev
+ samurai
+ wayland-protocols
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
+_repo_url="https://invent.kde.org/plasma/kwayland-integration.git"
source="https://download.kde.org/$_rel/plasma/$pkgver/kwayland-integration-$pkgver.tar.xz"
options="!check" # Broken
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -37,5 +43,5 @@ package() {
}
sha512sums="
-456b745e493965781178e1cd2fe64b8833294800ea152f5f95d00e1e2c221f97c2a29b91498573bc25710e3ad42482e46a4f0f33d5a57ce8ed1454a65fba81a9 kwayland-integration-5.22.5.tar.xz
+0caf516444afb9fa5b148461f1301fb865c691ad39f120c3919194be643492721210a2c1a584f8bcacef9ad2fd2f04a563eb18e3b388bb4322574fd0f2d590af kwayland-integration-6.0.3.tar.xz
"