aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland-integration/APKBUILD')
-rw-r--r--community/kwayland-integration/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 73c66da182e..3a8f29b35d8 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: Bhushan Shah <bshah@kde.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland-integration
-pkgver=5.25.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="KWayland integration"
url="https://kde.org/plasma-desktop/"
arch="all !armhf" # armhf blocked by extra-cmake-modules
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends="kglobalaccel"
+depends="kglobalaccel5"
makedepends="
extra-cmake-modules
- kguiaddons-dev
- kidletime-dev
- kwayland-dev
- kwindowsystem-dev
+ kguiaddons5-dev
+ kidletime5-dev
+ kwayland5-dev
+ kwindowsystem5-dev
qt5-qtbase-dev
samurai
wayland-protocols
@@ -23,6 +26,7 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
+_repo_url="https://invent.kde.org/plasma/kwayland-integration.git"
source="https://download.kde.org/$_rel/plasma/$pkgver/kwayland-integration-$pkgver.tar.xz"
options="!check" # Broken
@@ -39,5 +43,5 @@ package() {
}
sha512sums="
-0c7ce622c27f7a51da607442a7f05cef180197a153bf5a4fa16d95bf63665321511a973b93eb68788b0a9a481027de5383a1658539b1af25fef5443053d2b4ce kwayland-integration-5.25.2.tar.xz
+2fac1bf44212a0c70f89625bdf7169551e26d252299e740a3c0ee4c87a3172ed69549856c7cc0f2cb27b09c5b72fe4de14a186e2d513436708d839e95503157a kwayland-integration-6.0.4.tar.xz
"