aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland-integration/APKBUILD')
-rw-r--r--community/kwayland-integration/APKBUILD48
1 files changed, 30 insertions, 18 deletions
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 45aaf8b3c9a..3a8f29b35d8 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,35 +1,47 @@
# Contributor: Bhushan Shah <bshah@kde.org>
-# Maintainer: Bhushan Shah <bshah@kde.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland-integration
-pkgver=5.17.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="KWayland integration"
-url="https://www.kde.org/workspaces/plasmadesktop/"
+url="https://kde.org/plasma-desktop/"
arch="all !armhf" # armhf blocked by extra-cmake-modules
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends="kwayland kglobalaccel kidletime"
-makedepends="cmake extra-cmake-modules qt5-qtbase-dev kwayland-dev kwindowsystem-dev kidletime-dev kguiaddons-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/kwayland-integration-$pkgver.tar.xz"
-options="!check" # Broken
-
-prepare() {
- default_prepare
+depends="kglobalaccel5"
+makedepends="
+ extra-cmake-modules
+ kguiaddons5-dev
+ kidletime5-dev
+ kwayland5-dev
+ kwindowsystem5-dev
+ qt5-qtbase-dev
+ samurai
+ wayland-protocols
+ "
- mkdir "$builddir"/build
-}
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+_repo_url="https://invent.kde.org/plasma/kwayland-integration.git"
+source="https://download.kde.org/$_rel/plasma/$pkgver/kwayland-integration-$pkgver.tar.xz"
+options="!check" # Broken
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="50ac96f4ed957ed264e8f700dc9bdb71ce04cb4a6385c2316890171943c4b7a23ebba08eb7047eebd99ad7c6d485f440c8ae7375c040088ddfffbf7f5824634c kwayland-integration-5.17.5.tar.xz"
+sha512sums="
+2fac1bf44212a0c70f89625bdf7169551e26d252299e740a3c0ee4c87a3172ed69549856c7cc0f2cb27b09c5b72fe4de14a186e2d513436708d839e95503157a kwayland-integration-6.0.4.tar.xz
+"