aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland/APKBUILD')
-rw-r--r--community/kwayland/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/kwayland/APKBUILD b/community/kwayland/APKBUILD
index bb82386e824..4913dbf5570 100644
--- a/community/kwayland/APKBUILD
+++ b/community/kwayland/APKBUILD
@@ -1,30 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland
-pkgver=5.97.0
+pkgver=6.0.3
pkgrel=0
pkgdesc="Qt-style Client and Server library wrapper for the Wayland libraries"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
- qt5-qtwayland-dev
+ qt6-qtwayland-dev
wayland-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
plasma-wayland-protocols
- qt5-qtbase-dev
- qt5-qttools-dev
+ qt6-qtbase-dev
+ qt6-qttools-dev
wayland-protocols
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwayland-$pkgver.tar.xz
- 0001-PlasmaWindowManagement-Avoid-unbounded-recursion-and-delay-in-readData.patch
- "
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
-options="!check" # Fails due to requiring running Wayland compositor
+_repo_url="https://invent.kde.org/plasma/kwayland.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwayland-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -36,8 +42,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,6 +50,5 @@ package() {
}
sha512sums="
-694d7cd0e643f35c5c7bbf117240a6b7515f590c5738669755fe381549c71f1c760241da2ffc8661e06e95a5e7cbdc2dc4f3a8231d53d87a6933fefcee9491f9 kwayland-5.97.0.tar.xz
-d04e526a440d930187bc11df40b8d106ef034f27c8e5019f5aaea416994ad61f452b4d7a90880a0f9258acc2cafc0fef2530d692907783bb4e23cd913bcd7341 0001-PlasmaWindowManagement-Avoid-unbounded-recursion-and-delay-in-readData.patch
+8df9296ae9d06935b21c4c255f0d45722b504e6ab095c5c1beaba33a010652ab98d82e318119da3633daf56d8b8ef0343fdcf8c56a931bd6171afa1e98e13a04 kwayland-6.0.3.tar.xz
"