aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland/APKBUILD')
-rw-r--r--community/kwayland/APKBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/community/kwayland/APKBUILD b/community/kwayland/APKBUILD
index f7340f8c0b5..4bc0ec12fbc 100644
--- a/community/kwayland/APKBUILD
+++ b/community/kwayland/APKBUILD
@@ -1,31 +1,40 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland
-pkgver=5.84.0
+pkgver=6.0.4
pkgrel=0
pkgdesc="Qt-style Client and Server library wrapper for the Wayland libraries"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
- qt5-qtbase-dev
- qt5-qtwayland-dev
+ qt6-qtwayland-dev
wayland-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
plasma-wayland-protocols
- qt5-qttools-dev
+ qt6-qtbase-dev
+ qt6-qttools-dev
wayland-protocols
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwayland-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Fails due to requiring running Wayland compositor
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
+_repo_url="https://invent.kde.org/plasma/kwayland.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwayland-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -33,14 +42,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-e777a1713a6b95054b1361653fb6818d6aa7a4dd1d9d75ac389d4884f812f1436937ceecbc3327296d4902a85aa54a885d92728b3573b212722204da03bf7797 kwayland-5.84.0.tar.xz
+12db8acbd24716ee3321d2e8b47315dfa645dc447224eba7db80095d9f5eb41d61f7d3d8422f38a6d066313d0cc6994085b4bc9bb974e427b574a1aafd20a653 kwayland-6.0.4.tar.xz
"