aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwayland/APKBUILD')
-rw-r--r--community/kwayland/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/kwayland/APKBUILD b/community/kwayland/APKBUILD
index 7fba2acb99d..4913dbf5570 100644
--- a/community/kwayland/APKBUILD
+++ b/community/kwayland/APKBUILD
@@ -1,21 +1,40 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwayland
-pkgver=5.75.0
+pkgver=6.0.3
pkgrel=0
pkgdesc="Qt-style Client and Server library wrapper for the Wayland libraries"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org"
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtbase-dev qt5-qtwayland-dev wayland-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev wayland-protocols plasma-wayland-protocols"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwayland-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Fails due to requiring running Wayland compositor
+depends_dev="
+ qt6-qtwayland-dev
+ wayland-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ plasma-wayland-protocols
+ qt6-qtbase-dev
+ qt6-qttools-dev
+ wayland-protocols
+ samurai
+ "
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
+_repo_url="https://invent.kde.org/plasma/kwayland.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwayland-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -23,12 +42,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="8f77ccdf4f30bea2d6974d930734479c0f81f5309807b28f51bbcfda91977e27d5311b4718e4685609da0368c1e1bb060eaa765628a0ed9560f5774dcc357d8a kwayland-5.75.0.tar.xz"
+sha512sums="
+8df9296ae9d06935b21c4c255f0d45722b504e6ab095c5c1beaba33a010652ab98d82e318119da3633daf56d8b8ef0343fdcf8c56a931bd6171afa1e98e13a04 kwayland-6.0.3.tar.xz
+"