aboutsummaryrefslogtreecommitdiffstats
path: root/community/kweathercore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kweathercore/APKBUILD')
-rw-r--r--community/kweathercore/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/kweathercore/APKBUILD b/community/kweathercore/APKBUILD
index 3fc843246b5..9f19a706079 100644
--- a/community/kweathercore/APKBUILD
+++ b/community/kweathercore/APKBUILD
@@ -1,31 +1,40 @@
# Contributor: Devin Lin <espidev@gmail.com>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=kweathercore
-pkgver=0.6
+pkgver=0.8.0
pkgrel=0
pkgdesc="Library to facilitate retrieval of weather information including forecasts and alerts"
url="https://invent.kde.org/libraries/kweathercore"
-arch="all !armhf" # armhf blocked by qt5-qtlocation-dev
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="LGPL-2.0-or-later AND CC-BY-4.0"
depends_dev="
kholidays-dev
ki18n-dev
- qt5-qtbase-dev
- qt5-qtlocation-dev
+ qt6-qtbase-dev
+ qt6-qtlocation-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/libraries/kweathercore.git"
source="https://download.kde.org/stable/kweathercore/$pkgver/kweathercore-$pkgver.tar.xz"
options="!check" # No tests
-subpackages="$pkgname-dev $pkgname-lang"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
@@ -34,5 +43,5 @@ package() {
}
sha512sums="
-0cc3a5422052fd4d3bedac36c3c017d1ed5c21c4200f6e747dc478bab55f7207d9207a9ea472c340397cd2433a020b92adb6ab39f054b4cd6c72cf01949d18d2 kweathercore-0.6.tar.xz
+eed813f528422969aed17b831bf6153e49595cf148bb9bda477acdf76d41922eededa55f312d075ccf7bece9e8291dddc0efc92713073fc3c99f438cc0844b69 kweathercore-0.8.0.tar.xz
"