aboutsummaryrefslogtreecommitdiffstats
path: root/community/kweathercore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kweathercore/APKBUILD')
-rw-r--r--community/kweathercore/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/kweathercore/APKBUILD b/community/kweathercore/APKBUILD
index df3e5b09e04..9f19a706079 100644
--- a/community/kweathercore/APKBUILD
+++ b/community/kweathercore/APKBUILD
@@ -1,27 +1,40 @@
# Contributor: Devin Lin <espidev@gmail.com>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=kweathercore
-pkgver=0.5
+pkgver=0.8.0
pkgrel=0
pkgdesc="Library to facilitate retrieval of weather information including forecasts and alerts"
url="https://invent.kde.org/libraries/kweathercore"
-arch="all !armhf" # armhf blocked by qt5-qtlocation-dev
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="LGPL-2.0-or-later AND CC-BY-4.0"
depends_dev="
+ kholidays-dev
ki18n-dev
- qt5-qtbase-dev
- qt5-qtlocation-dev
+ qt6-qtbase-dev
+ qt6-qtlocation-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
"
-makedepends="$depends_dev extra-cmake-modules"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/libraries/kweathercore.git"
source="https://download.kde.org/stable/kweathercore/$pkgver/kweathercore-$pkgver.tar.xz"
options="!check" # No tests
-subpackages="$pkgname-dev $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
@@ -29,7 +42,6 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-
sha512sums="
-b11d19d28856c098d219bccdd4868db93707aae4fc98d2e1ac3fe982faf9c8628c86e301e0bb9082b842a80cb8b3995bc3cffdd494e0b653899e13adac70f93e kweathercore-0.5.tar.xz
+eed813f528422969aed17b831bf6153e49595cf148bb9bda477acdf76d41922eededa55f312d075ccf7bece9e8291dddc0efc92713073fc3c99f438cc0844b69 kweathercore-0.8.0.tar.xz
"