aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwin/APKBUILD')
-rw-r--r--community/kwin/APKBUILD69
1 files changed, 42 insertions, 27 deletions
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 64453512a1c..20fbeba5313 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -1,25 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwin
-pkgver=5.22.5
+pkgver=6.0.3.1
pkgrel=0
pkgdesc="An easy to use, but flexible, composited Window Manager"
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by kscreenlocker
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
depends="
- kirigami2
- qt5-qtmultimedia
- qt5-qtwayland
+ hwdata
+ kirigami
+ qt6-qtmultimedia
+ qt6-qtwayland
xwayland
"
-depends_dev="
+depends_dev="$pkgname
breeze-dev
eudev-dev
fontconfig-dev
- kactivities-dev
kcmutils-dev
kcompletion-dev
kconfig-dev
@@ -32,7 +34,6 @@ depends_dev="
ki18n-dev
kiconthemes-dev
kidletime-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -40,9 +41,9 @@ depends_dev="
krunner-dev
kscreenlocker-dev
kservice-dev
+ ksvg-dev
ktextwidgets-dev
kwayland-dev
- kwayland-server-dev
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
@@ -50,18 +51,18 @@ depends_dev="
libdrm-dev
libepoxy-dev
libinput-dev
+ libplasma-dev
libqaccessibilityclient-dev
+ libxcvt-dev
libxi-dev
libxkbcommon-dev
mesa-dev
mesa-gbm
pipewire-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtscript-dev
- qt5-qtsensors-dev
- qt5-qtx11extras-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsensors-dev
wayland-dev
xcb-util-cursor-dev
xcb-util-image-dev
@@ -70,7 +71,13 @@ depends_dev="
makedepends="$depends_dev
extra-cmake-modules
kdoctools-dev
- qt5-qttools-dev
+ kglobalacceld-dev
+ kpipewire-dev
+ libcap-utils
+ libdisplay-info-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -78,21 +85,28 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwin-$pkgver.tar.xz"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Broken
+_repo_url="https://invent.kde.org/plasma/kwin.git"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/kwin-$pkgver.tar.xz
+ 0001-$pkgname-Fix-building-of-tests.patch::https://invent.kde.org/plasma/kwin/-/commit/a879c59a082707e0e7dfa8ebeb7b239551ec9c71.patch
+ "
+# Broken, fails to setup due to missing or invalid XDG_RUNTIME_DIR?
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ # significantly reduce debug symbol size
+ # use None here to not make cmake pass bare -g (-g2)
+ CFLAGS="$CFLAGS -O2 -g1" CXXFLAGS="$CXXFLAGS -O2 -g1" \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ XDG_RUNTIME_DIR="$(mktemp -p -d "$builddir")" \
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -104,8 +118,9 @@ package() {
# kwin_wayland has CAP_SYS_NICE set. Because of this, libdbus doesn't trust the
# environment and ignores it, causing for example keyboard shortcuts to not work
# Remove CAP_SYS_NICE from kwin_wayland to make them work again
- setcap -r "$pkgdir"/usr/bin/kwin_wayland
+
}
sha512sums="
-4e466f3961279610c16d24c1dbc6368862308ee7bf677bf9f8ed1898465aa31263a34362b1beaad451b6c5e94068d908718c7bb37d12b814f2af9a1eccf417d2 kwin-5.22.5.tar.xz
+e4a7610fbefcd0903fcc3b68466d085981adb5678cd00a5eae546dd281e601eb07df50c190e5858dd0df42848ae2841ac8c0efdd1b765892cbe1aeb4f52eaab0 kwin-6.0.3.1.tar.xz
+14c4ddceca2ef51a139319bdd64bc84d7a1df7c6419e86bdbb04572be3212ca46f5c25cd61fa3b511d7644046f92a07408e472e41d95aab93ec494138a09c1a9 0001-kwin-Fix-building-of-tests.patch
"