aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwin/APKBUILD')
-rw-r--r--community/kwin/APKBUILD57
1 files changed, 34 insertions, 23 deletions
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 08829f6dae6..6a894c70953 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -1,24 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwin
-pkgver=5.25.4
+pkgver=6.0.4.1
pkgrel=0
pkgdesc="An easy to use, but flexible, composited Window Manager"
-# armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt6-qtdeclarative
arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
depends="
- kirigami2
- qt5-qtmultimedia
- qt5-qtwayland
+ hwdata
+ kirigami
+ qt6-qtmultimedia
+ qt6-qtwayland
xwayland
"
-depends_dev="
+depends_dev="$pkgname
breeze-dev
eudev-dev
fontconfig-dev
- kactivities-dev
kcmutils-dev
kcompletion-dev
kconfig-dev
@@ -31,7 +34,6 @@ depends_dev="
ki18n-dev
kiconthemes-dev
kidletime-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -39,6 +41,7 @@ depends_dev="
krunner-dev
kscreenlocker-dev
kservice-dev
+ ksvg-dev
ktextwidgets-dev
kwayland-dev
kwidgetsaddons-dev
@@ -48,6 +51,7 @@ depends_dev="
libdrm-dev
libepoxy-dev
libinput-dev
+ libplasma-dev
libqaccessibilityclient-dev
libxcvt-dev
libxi-dev
@@ -55,12 +59,10 @@ depends_dev="
mesa-dev
mesa-gbm
pipewire-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtscript-dev
- qt5-qtsensors-dev
- qt5-qtx11extras-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsensors-dev
wayland-dev
xcb-util-cursor-dev
xcb-util-image-dev
@@ -69,8 +71,12 @@ depends_dev="
makedepends="$depends_dev
extra-cmake-modules
kdoctools-dev
+ kglobalacceld-dev
+ kpipewire-dev
libcap-utils
- qt5-qttools-dev
+ libdisplay-info-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
@@ -79,24 +85,28 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwin-$pkgver.tar.xz"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Broken
+_repo_url="https://invent.kde.org/plasma/kwin.git"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/kwin-$pkgver.tar.xz
+ 0001-kwin-Fix-building-of-tests.patch
+ "
+# Broken, fails to setup due to missing or invalid XDG_RUNTIME_DIR?
+options="!check"
build() {
# significantly reduce debug symbol size
# use None here to not make cmake pass bare -g (-g2)
CFLAGS="$CFLAGS -O2 -g1" CXXFLAGS="$CXXFLAGS -O2 -g1" \
cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ XDG_RUNTIME_DIR="$(mktemp -p -d "$builddir")" \
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -108,8 +118,9 @@ package() {
# kwin_wayland has CAP_SYS_NICE set. Because of this, libdbus doesn't trust the
# environment and ignores it, causing for example keyboard shortcuts to not work
# Remove CAP_SYS_NICE from kwin_wayland to make them work again
- setcap -r "$pkgdir"/usr/bin/kwin_wayland
+
}
sha512sums="
-14ffb4ea0eb069811803253b8abb7737eecb5c121c99c477c1b085a80812eae10d9e2012e3343b326f1a3258a2854d1f8b138dad2f31e548835b9bf09769c0fd kwin-5.25.4.tar.xz
+a38605dea13a225220544b77f835bff5bb191861ad34dd5ea6de06069921bc6db1f2683cb361d421ab3f7a82c58d2ff914512074a17e8e554bac3e5303f19ab5 kwin-6.0.4.1.tar.xz
+14c4ddceca2ef51a139319bdd64bc84d7a1df7c6419e86bdbb04572be3212ca46f5c25cd61fa3b511d7644046f92a07408e472e41d95aab93ec494138a09c1a9 0001-kwin-Fix-building-of-tests.patch
"