aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwindowsystem/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwindowsystem/APKBUILD')
-rw-r--r--community/kwindowsystem/APKBUILD40
1 files changed, 27 insertions, 13 deletions
diff --git a/community/kwindowsystem/APKBUILD b/community/kwindowsystem/APKBUILD
index 6b27c929bc5..3fac74be2a4 100644
--- a/community/kwindowsystem/APKBUILD
+++ b/community/kwindowsystem/APKBUILD
@@ -1,21 +1,37 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kwindowsystem
-pkgver=5.84.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Access to the windowing system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="MIT AND (LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen libxrender-dev xcb-util-keysyms-dev xcb-util-wm-dev"
+depends_dev="
+ libxrender-dev
+ plasma-wayland-protocols
+ qt6-qtwayland-dev
+ xcb-util-keysyms-dev
+ xcb-util-wm-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwindowsystem-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kwindowsystem.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwindowsystem-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -23,8 +39,6 @@ build() {
}
check() {
- cd build
-
# kwindowsystem-kwindowinfox11test hangs
# kwindowsystem-kwindowsystemx11test, kwindowsystem-kwindowsystem_threadtest and kwindowsystem-netrootinfotestwm are broken
# kwindowsystem-netwininfotestwm is broken on s390x
@@ -44,13 +58,13 @@ check() {
skipped_tests="$skipped_tests|$test"
done
skipped_tests="$skipped_tests)"
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "$skipped_tests"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-9a849049e7480f6d3f6e1fdbfa540b6c99c9a225afff71ba31152cf4dd79b2c56eadf68b2992c3258f76568f89ab595c494d0baec4a5efff672f92983ec534bd kwindowsystem-5.84.0.tar.xz
+80d7270bc26ca8c7914b2c5d10f014afa033c076a970f82b2d5a0063178349f8f0b430deeba5eb10ea69e8ab42783d50597c3cccc7f749ccee9df48683be1919 kwindowsystem-6.0.0.tar.xz
"