aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwindowsystem/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwindowsystem/APKBUILD')
-rw-r--r--community/kwindowsystem/APKBUILD36
1 files changed, 25 insertions, 11 deletions
diff --git a/community/kwindowsystem/APKBUILD b/community/kwindowsystem/APKBUILD
index 6c21cf7a326..94d99d806f2 100644
--- a/community/kwindowsystem/APKBUILD
+++ b/community/kwindowsystem/APKBUILD
@@ -1,17 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kwindowsystem
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Access to the windowing system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="MIT AND (LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen libxrender-dev xcb-util-keysyms-dev xcb-util-wm-dev samurai"
+depends_dev="
+ libxrender-dev
+ plasma-wayland-protocols
+ qt6-qtwayland-dev
+ xcb-util-keysyms-dev
+ xcb-util-wm-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwindowsystem-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kwindowsystem.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwindowsystem-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -23,8 +39,6 @@ build() {
}
check() {
- cd build
-
# kwindowsystem-kwindowinfox11test hangs
# kwindowsystem-kwindowsystemx11test, kwindowsystem-kwindowsystem_threadtest and kwindowsystem-netrootinfotestwm are broken
# kwindowsystem-netwininfotestwm is broken on s390x
@@ -44,13 +58,13 @@ check() {
skipped_tests="$skipped_tests|$test"
done
skipped_tests="$skipped_tests)"
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "$skipped_tests"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-ed1df6fcc3dad2f8a318e7402c7e72f620523bc39ad54dbf032c6c11384c788b59ec075c83631caa473c6450504fa0564f66770b54a873aa04d8e2c059a03c5a kwindowsystem-5.95.0.tar.xz
+b538c39c14a5bc11b599e9297cf553830f7eec832cb42c77ab2008f3a9f02fc7ccc18ea0d5d0de9f31d38d900367e1518f2dbc8fc85957458cddee6c9c191071 kwindowsystem-6.1.0.tar.xz
"