aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwrited/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwrited/APKBUILD')
-rw-r--r--community/kwrited/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/kwrited/APKBUILD b/community/kwrited/APKBUILD
index 9737b05a27f..33e01304077 100644
--- a/community/kwrited/APKBUILD
+++ b/community/kwrited/APKBUILD
@@ -1,10 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kwrited
-pkgver=5.24.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="KDE daemon listening for wall and write messages"
-arch="all !armhf" # qt5-qtdeclarative-dev unavilable on armhf
+arch="all !armhf" # qt6-qtdeclarative-dev unavilable on armhf
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
makedepends="
@@ -14,7 +17,7 @@ makedepends="
ki18n-dev
knotifications-dev
kpty-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
@@ -22,8 +25,10 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kwrited-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/kwrited.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kwrited-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -38,5 +43,5 @@ package() {
}
sha512sums="
-3fd38606fd81017f54df910e47f62bdc82758205fdeacae80a5bca6c5fe7ce9413a4f3f7c3ce2735107c6cd6ebecbc5a929b809eef52a593cc69c358c7c38af4 kwrited-5.24.5.tar.xz
+736521989b7163b50e657dfcbeabb0ab23566ee15446a609013c1cfde7852d19c7b45baf881ef0745089bd13d530ab9a5689cd1782f238297a5f6abbbc85945e kwrited-6.0.3.tar.xz
"