aboutsummaryrefslogtreecommitdiffstats
path: root/community/lab/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lab/APKBUILD')
-rw-r--r--community/lab/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/lab/APKBUILD b/community/lab/APKBUILD
index 6bdf2dad4d5..13b478bd90b 100644
--- a/community/lab/APKBUILD
+++ b/community/lab/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lab
-pkgver=0.24.0
-pkgrel=1
+pkgver=0.25.1
+pkgrel=17
pkgdesc="Git Wrapper for GitLab"
url="https://zaquestion.github.io/lab/"
arch="all"
@@ -18,7 +18,9 @@ subpackages="
source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz"
options="net !check chmod-clean" # Tests require configured GitLab account with SSH keys
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -ldflags "-X main.version=$pkgver" -o bin/$pkgname
@@ -35,9 +37,9 @@ package() {
install -Dm644 "$builddir"/_lab.zsh \
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
install -Dm644 "$builddir"/lab.fish \
- "$pkgdir"/usr/share/fish/completions/$pkgname.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
}
sha512sums="
-53e57b3f63daadaf9e1bf9b89edeb8b398ac1fbb3c57732b75534555e14000d93bd2ade9ee52863715795284d90a7e95a66fe95e708a216c75eb42b0f0c97aca lab-0.24.0.tar.gz
+891605f0572c9deff27b5583782b59361fd99a2559f9ac84a77f9a9d323ba54b97ac79bfed4ea63e8a421e38a63b3ea713a67c42ecd45ca895d29b2f826e8859 lab-0.25.1.tar.gz
"