aboutsummaryrefslogtreecommitdiffstats
path: root/community/labwc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/labwc/APKBUILD')
-rw-r--r--community/labwc/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/labwc/APKBUILD b/community/labwc/APKBUILD
index 08758e484d3..d09302b939a 100644
--- a/community/labwc/APKBUILD
+++ b/community/labwc/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=labwc
-pkgver=0.5.2
+pkgver=0.7.1
pkgrel=0
pkgdesc="Wayland stacking compositor"
url="https://github.com/labwc/labwc"
arch="all"
license="GPL-2.0-only"
+depends="xwayland"
makedepends="
cairo-dev
glib-dev
libinput-dev
+ librsvg-dev
libxml2-dev
meson
pango-dev
@@ -18,17 +20,18 @@ makedepends="
wayland-protocols
wlroots-dev
"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/labwc/labwc/archive/$pkgver/labwc-$pkgver.tar.gz
- remove-aports-git-version.patch"
+ remove-aports-git-version.patch
+ "
build() {
abuild-meson . output -Dman-pages=enabled
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -36,6 +39,6 @@ package() {
}
sha512sums="
-826ebab6b9b018d10418f2b89304c7ec16ba67b5ecc2cce2b9a61cdd70ae5517cb5f3250c637b1c55dd40847c56ab3b67c7e2963ffd857ae215809f84e444b4d labwc-0.5.2.tar.gz
+2fb307887ae210bc7f0025b2ae9046345de9d1a8dfa0aac3817d7aa4fdbffc7cbc176ec3a859e2328404cd97910d434e9897f7b614fc55d8eab729f0a5007e97 labwc-0.7.1.tar.gz
08b1c7f45eda434400b61b8cad1d0e800c8f4ecd9e3f93fc42b10f4e8e0e599ed61a7a7e363dfa0acb45b174269278c136a244ec87940e84cc2362cdda5f5ef6 remove-aports-git-version.patch
"