aboutsummaryrefslogtreecommitdiffstats
path: root/community/labwc/remove-aports-git-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/labwc/remove-aports-git-version.patch')
-rw-r--r--community/labwc/remove-aports-git-version.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/labwc/remove-aports-git-version.patch b/community/labwc/remove-aports-git-version.patch
new file mode 100644
index 00000000000..4cdd2cf3e8b
--- /dev/null
+++ b/community/labwc/remove-aports-git-version.patch
@@ -0,0 +1,16 @@
+--- a/meson.build
++++ b/meson.build
+@@ -28,13 +28,6 @@
+ )
+
+ version='"@0@"'.format(meson.project_version())
+-git = find_program('git', native: true, required: false)
+-if git.found()
+- git_commit = run_command([git, 'describe', '--dirty'], check: false)
+- if git_commit.returncode() == 0
+- version = '"@0@"'.format(git_commit.stdout().strip())
+- endif
+-endif
+ add_project_arguments('-DLABWC_VERSION=@0@'.format(version), language: 'c')
+
+ wlroots = dependency(