aboutsummaryrefslogtreecommitdiffstats
path: root/community/lastpass-cli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lastpass-cli/APKBUILD')
-rw-r--r--community/lastpass-cli/APKBUILD41
1 files changed, 28 insertions, 13 deletions
diff --git a/community/lastpass-cli/APKBUILD b/community/lastpass-cli/APKBUILD
index bb069177023..bfbfa38418d 100644
--- a/community/lastpass-cli/APKBUILD
+++ b/community/lastpass-cli/APKBUILD
@@ -1,32 +1,46 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lastpass-cli
-pkgver=1.3.3
-pkgrel=3
+pkgver=1.3.7
+pkgrel=0
pkgdesc="LastPass command line interface tool"
url="https://lastpass.com"
arch="all"
license="GPL-2.0-or-later"
-makedepends="asciidoc bash cmake curl-dev openssl1.1-compat-dev libxml2-dev"
-subpackages="$pkgname-doc
+makedepends="
+ asciidoc
+ cmake
+ curl-dev
+ libxml2-dev
+ openssl-dev>3
+ samurai
+ "
+checkdepends="bash"
+subpackages="
+ $pkgname-doc
$pkgname-zsh-completion
$pkgname-bash-completion
$pkgname-fish-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz
- e3311cebdb29a3267843cf656a32f01c5062897e.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz"
build() {
- make all
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/share/man
+ cmake --build build
+ if want_check; then
+ cmake --build build --target lpass-test
+ fi
}
check() {
- make test
+ ctest --test-dir build --output-on-failure -j1
}
package() {
- make DESTDIR="$pkgdir" install install-doc
+ DESTDIR="$pkgdir" cmake --build build --target install install-doc
install -D -m644 "$builddir"/contrib/lpass_zsh_completion \
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
@@ -35,8 +49,9 @@ package() {
"$pkgdir"/usr/share/bash-completion/completions/$pkgname.bash
install -D -m644 "$builddir"/contrib/completions-lpass.fish \
- "$pkgdir"/usr/share/fish/completions/$pkgname.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
}
-sha512sums="9b9274cae1fe4045b7df4402170c522ab5765929739e76141b35a75ce3c8af824acd881e194face45e8721d6ce778bde97ff1a1ac23515de0c6dba28d61a8c7e lastpass-cli-1.3.3.tar.gz
-0f624e6b83d7d193089b2b13d03f261dc8e9df88cafa9b295ad55a6242ef5cca65c2d8ecb3d7330034a1b3d1bfef4a76d5d07491439f0360ac285cba4f050de5 e3311cebdb29a3267843cf656a32f01c5062897e.patch"
+sha512sums="
+23128bf93f63c2d9154e533a3e15c3fea508fade151fe374327a2ae9994013f7b058c936e03753168be81bb19b22c217e88fc3e909b05658c6f827302c0be653 lastpass-cli-1.3.7.tar.gz
+"