aboutsummaryrefslogtreecommitdiffstats
path: root/community/lastpass-cli
diff options
context:
space:
mode:
Diffstat (limited to 'community/lastpass-cli')
-rw-r--r--community/lastpass-cli/APKBUILD41
-rw-r--r--community/lastpass-cli/e3311cebdb29a3267843cf656a32f01c5062897e.patch47
2 files changed, 28 insertions, 60 deletions
diff --git a/community/lastpass-cli/APKBUILD b/community/lastpass-cli/APKBUILD
index bb069177023..bfbfa38418d 100644
--- a/community/lastpass-cli/APKBUILD
+++ b/community/lastpass-cli/APKBUILD
@@ -1,32 +1,46 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lastpass-cli
-pkgver=1.3.3
-pkgrel=3
+pkgver=1.3.7
+pkgrel=0
pkgdesc="LastPass command line interface tool"
url="https://lastpass.com"
arch="all"
license="GPL-2.0-or-later"
-makedepends="asciidoc bash cmake curl-dev openssl1.1-compat-dev libxml2-dev"
-subpackages="$pkgname-doc
+makedepends="
+ asciidoc
+ cmake
+ curl-dev
+ libxml2-dev
+ openssl-dev>3
+ samurai
+ "
+checkdepends="bash"
+subpackages="
+ $pkgname-doc
$pkgname-zsh-completion
$pkgname-bash-completion
$pkgname-fish-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz
- e3311cebdb29a3267843cf656a32f01c5062897e.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz"
build() {
- make all
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/share/man
+ cmake --build build
+ if want_check; then
+ cmake --build build --target lpass-test
+ fi
}
check() {
- make test
+ ctest --test-dir build --output-on-failure -j1
}
package() {
- make DESTDIR="$pkgdir" install install-doc
+ DESTDIR="$pkgdir" cmake --build build --target install install-doc
install -D -m644 "$builddir"/contrib/lpass_zsh_completion \
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
@@ -35,8 +49,9 @@ package() {
"$pkgdir"/usr/share/bash-completion/completions/$pkgname.bash
install -D -m644 "$builddir"/contrib/completions-lpass.fish \
- "$pkgdir"/usr/share/fish/completions/$pkgname.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
}
-sha512sums="9b9274cae1fe4045b7df4402170c522ab5765929739e76141b35a75ce3c8af824acd881e194face45e8721d6ce778bde97ff1a1ac23515de0c6dba28d61a8c7e lastpass-cli-1.3.3.tar.gz
-0f624e6b83d7d193089b2b13d03f261dc8e9df88cafa9b295ad55a6242ef5cca65c2d8ecb3d7330034a1b3d1bfef4a76d5d07491439f0360ac285cba4f050de5 e3311cebdb29a3267843cf656a32f01c5062897e.patch"
+sha512sums="
+23128bf93f63c2d9154e533a3e15c3fea508fade151fe374327a2ae9994013f7b058c936e03753168be81bb19b22c217e88fc3e909b05658c6f827302c0be653 lastpass-cli-1.3.7.tar.gz
+"
diff --git a/community/lastpass-cli/e3311cebdb29a3267843cf656a32f01c5062897e.patch b/community/lastpass-cli/e3311cebdb29a3267843cf656a32f01c5062897e.patch
deleted file mode 100644
index e761962c742..00000000000
--- a/community/lastpass-cli/e3311cebdb29a3267843cf656a32f01c5062897e.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From e3311cebdb29a3267843cf656a32f01c5062897e Mon Sep 17 00:00:00 2001
-From: Eric Engestrom <eric@engestrom.ch>
-Date: Sun, 25 Oct 2020 09:49:29 +0100
-Subject: [PATCH] Fix GCC 10+ build
-
-GCC 10 changed the default option from `-fcommon` to `-fno-common`.
-
-A quick and dirty fix could be to just set `-fcommon` in CMakeLists.txt,
-but the proper fix is to move the variables to a single compilation unit
-and simply reference them in the other CU, instead of each CU having its
-own copy.
-
-Signed-off-by: Eric Engestrom <eric@engestrom.ch>
----
- process.c | 3 +++
- process.h | 4 ++--
- 2 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/process.c b/process.c
-index 59bdf10..8ccbf34 100644
---- a/process.c
-+++ b/process.c
-@@ -127,6 +127,9 @@ static int pid_to_cmd(pid_t pid, char *cmd, size_t cmd_size)
- #error "Please provide a pid_to_cmd for your platform"
- #endif
-
-+int ARGC;
-+char **ARGV;
-+
- void process_set_name(const char *name)
- {
- size_t argslen = 0;
-diff --git a/process.h b/process.h
-index 58c2480..4cc2cf4 100644
---- a/process.h
-+++ b/process.h
-@@ -4,8 +4,8 @@
- #include <stdbool.h>
- #include <sys/types.h>
-
--int ARGC;
--char **ARGV;
-+extern int ARGC;
-+extern char **ARGV;
-
- void process_set_name(const char *name);
- void process_disable_ptrace(void);