aboutsummaryrefslogtreecommitdiffstats
path: root/community/layer-shell-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/layer-shell-qt/APKBUILD')
-rw-r--r--community/layer-shell-qt/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/layer-shell-qt/APKBUILD b/community/layer-shell-qt/APKBUILD
index d88049c8c88..fa46c6f509b 100644
--- a/community/layer-shell-qt/APKBUILD
+++ b/community/layer-shell-qt/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=layer-shell-qt
-pkgver=5.23.4
+pkgver=6.0.3
pkgrel=0
pkgdesc="Qt component to allow applications to make use of the Wayland wl-layer-shell protocol"
# armhf blocked by extra-cmake-modules
@@ -9,11 +12,12 @@ arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
depends_dev="
- qt5-qtdeclarative-dev
- qt5-qtwayland-dev
+ qt6-qtdeclarative-dev
+ qt6-qtwayland-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
wayland-protocols
"
@@ -21,12 +25,13 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/layer-shell-qt-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/plasma/layer-shell-qt.git"
+source="https://download.kde.org/stable/plasma/$pkgver/layer-shell-qt-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_TESTING=ON
@@ -34,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +47,5 @@ package() {
}
sha512sums="
-d605e057e578e5e756537b72bcea434d51c9e4d36952eb891580fb6ef8d132aa41d95ab7530893ca2d977b46172bb2d63febb7282d191c12e73455a69142b7b4 layer-shell-qt-5.23.4.tar.xz
+df7d5e4768d8b24948b99833b66c2b3be91a125779ececf2dc706d5b641853209acecb84cba1e977b0951eb8b11fe667f017f95f71a12c8db06f9fb7236093c2 layer-shell-qt-6.0.3.tar.xz
"