aboutsummaryrefslogtreecommitdiffstats
path: root/community/layer-shell-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/layer-shell-qt/APKBUILD')
-rw-r--r--community/layer-shell-qt/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/layer-shell-qt/APKBUILD b/community/layer-shell-qt/APKBUILD
index 7ea1e8de874..f8c4cbbb1ea 100644
--- a/community/layer-shell-qt/APKBUILD
+++ b/community/layer-shell-qt/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=layer-shell-qt
-pkgver=5.22.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="Qt component to allow applications to make use of the Wayland wl-layer-shell protocol"
# armhf blocked by extra-cmake-modules
@@ -9,11 +12,12 @@ arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
depends_dev="
- qt5-qtdeclarative-dev
- qt5-qtwayland-dev
+ qt6-qtdeclarative-dev
+ qt6-qtwayland-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
wayland-protocols
"
@@ -21,12 +25,13 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/layer-shell-qt-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/plasma/layer-shell-qt.git"
+source="https://download.kde.org/stable/plasma/$pkgver/layer-shell-qt-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_TESTING=ON
@@ -34,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +47,5 @@ package() {
}
sha512sums="
-5bb85f73d68eb47b9fcad18e5d52ce22bddb73a486710dc2b47e5eb5f3ffee9674969505e55bdedbae19669c9568f9b4276a739aa1cde326c7795a199e6776d2 layer-shell-qt-5.22.5.tar.xz
+0eaa28103023c63d9df2c1d9ebd221c2ac1a0198f45923cfd521a3107eaf9498b9d6c0b3a98e15fa2aec229de92b1aa2760c6a35a813511d2b7befe22a73f51f layer-shell-qt-6.0.4.tar.xz
"