aboutsummaryrefslogtreecommitdiffstats
path: root/community/laz-perf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/laz-perf/APKBUILD')
-rw-r--r--community/laz-perf/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/community/laz-perf/APKBUILD b/community/laz-perf/APKBUILD
index 1a3d3f40d56..515bbbe4694 100644
--- a/community/laz-perf/APKBUILD
+++ b/community/laz-perf/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=laz-perf
-pkgver=3.0.0
-pkgrel=0
+pkgver=3.4.0
+pkgrel=1
pkgdesc="Alternative LAZ implementation for C++ and JavaScript"
-url="https://github.com/hobu/laz-perf"
+url="https://github.com/hobuinc/laz-perf"
# armhf, armv7: io_test segfaults
-# mips, mips64, s390x: broken on big endian
-arch="all !armhf !armv7 !s390x !mips !mips64"
-license="LGPL-2.0-or-later"
+# s390x: broken on big endian
+arch="all !armhf !armv7 !s390x"
+license="Apache-2.0"
depends_dev="$pkgname"
makedepends="
cmake
@@ -16,7 +16,7 @@ makedepends="
samurai
"
subpackages="$pkgname-dev"
-source="https://github.com/hobu/laz-perf/archive/$pkgver/laz-perf-$pkgver.tar.gz"
+source="https://github.com/hobuinc/laz-perf/archive/$pkgver/laz-perf-$pkgver.tar.gz"
build() {
cmake -B build -G Ninja \
@@ -27,8 +27,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -36,5 +35,5 @@ package() {
}
sha512sums="
-57fcbf661c306b01f86254c4471de68f7359d050cc562ff549ab3560f54f9a4455624740335009d2dfd6d9b3298c4742198106886ba1b0c97d4dfdeddeb180c0 laz-perf-3.0.0.tar.gz
+ec3e133d671a388f9cc448599035a57d0334015f18e6787ed05e463b4d3eddb5a4a09336a410f23c24d590d0d3242f3621ab49d4ce1400f226112e26f0759311 laz-perf-3.4.0.tar.gz
"