aboutsummaryrefslogtreecommitdiffstats
path: root/community/lazydocker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lazydocker/APKBUILD')
-rw-r--r--community/lazydocker/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/lazydocker/APKBUILD b/community/lazydocker/APKBUILD
new file mode 100644
index 00000000000..7f8148fb917
--- /dev/null
+++ b/community/lazydocker/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Thomas Deutsch <thomas@tuxpeople.org>
+# Maintainer: Thomas Deutsch <thomas@tuxpeople.org>
+pkgname=lazydocker
+pkgver=0.23.1
+pkgrel=2
+pkgdesc="Simple terminal UI for both docker and docker-compose"
+url="https://github.com/jesseduffield/lazydocker"
+arch="all"
+license="MIT"
+makedepends="go"
+options="chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jesseduffield/lazydocker/archive/v$pkgver.tar.gz"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ go build
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/lazydocker
+}
+
+sha512sums="
+10620d2c1fd6d6aaad00648aef4c5812e5e7a1fbc325bd2ec1e4d8a3e032f86d11479f25947b48cadce400659f87da5bf580cafb3ef4b5b33ac352008747094e lazydocker-0.23.1.tar.gz
+"