aboutsummaryrefslogtreecommitdiffstats
path: root/community/lazygit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lazygit/APKBUILD')
-rw-r--r--community/lazygit/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/lazygit/APKBUILD b/community/lazygit/APKBUILD
index 739dfd0c49c..352b74d7995 100644
--- a/community/lazygit/APKBUILD
+++ b/community/lazygit/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Thomas Deutsch <thomas@tuxpeople.org>
# Maintainer: Thomas Deutsch <thomas@tuxpeople.org>
pkgname=lazygit
-pkgver=0.34
+pkgver=0.41.0
pkgrel=1
pkgdesc="Simple terminal UI for git commands"
url="https://github.com/jesseduffield/lazygit"
arch="all"
license="MIT"
-depends="ncurses"
+# bash: for running git commands
+depends="ncurses bash"
makedepends="go"
options="!check" # FIXME: https://github.com/jesseduffield/lazygit/issues/1009
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jesseduffield/lazygit/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -ldflags="-X main.version=$pkgver" -v
@@ -28,7 +30,6 @@ package() {
install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
}
-
sha512sums="
-a63dd877220c124282667acaadd2f9c55c47687e0c65caff9f61c5a6a3cecc202501fdbd3a1ee13752c8e68bbbb920b5b198459e71a44c585d594675b931d5c2 lazygit-0.34.tar.gz
+ef1d8e2394eb3230c0489e0b0c6726536649697943fa8a7cbf95e9eb600c8fe3429e72539897f04ffd3ee35905b96600c5a79174856c4e49a22fbeada668bf4e lazygit-0.41.0.tar.gz
"