aboutsummaryrefslogtreecommitdiffstats
path: root/community/lazygit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lazygit/APKBUILD')
-rw-r--r--community/lazygit/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/lazygit/APKBUILD b/community/lazygit/APKBUILD
index 5434ed77bb6..352b74d7995 100644
--- a/community/lazygit/APKBUILD
+++ b/community/lazygit/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Thomas Deutsch <thomas@tuxpeople.org>
# Maintainer: Thomas Deutsch <thomas@tuxpeople.org>
pkgname=lazygit
-pkgver=0.32.2
-pkgrel=0
+pkgver=0.41.0
+pkgrel=1
pkgdesc="Simple terminal UI for git commands"
url="https://github.com/jesseduffield/lazygit"
arch="all"
license="MIT"
-depends="ncurses"
+# bash: for running git commands
+depends="ncurses bash"
makedepends="go"
options="!check" # FIXME: https://github.com/jesseduffield/lazygit/issues/1009
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jesseduffield/lazygit/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -ldflags="-X main.version=$pkgver" -v
@@ -28,7 +30,6 @@ package() {
install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
}
-
sha512sums="
-ee0e413e6e5cbbece76989220e094f105fbba0e35ba9940b04f8b1cf2bbc3a81d229dd953ada12a009bba005ce457516d79711eed90b049e1ca911fb74877d4b lazygit-0.32.2.tar.gz
+ef1d8e2394eb3230c0489e0b0c6726536649697943fa8a7cbf95e9eb600c8fe3429e72539897f04ffd3ee35905b96600c5a79174856c4e49a22fbeada668bf4e lazygit-0.41.0.tar.gz
"